Help Debugging?

Help Debugging?

Postby qwertyman20 » Sat Aug 09, 2014 9:52 pm

I know it's probably a bad idea to ask, but I'm just touching base here and making sure what I'm doing is the correct thing.

I'm hoping I can have someone's help on debugging and figuring out why my Inform doesn't seem to want to run FS. I know how to patch my own code in a few languages, but with inform and all of these extensions, I'm not sure if the issue is exactly where the error page says it is. (I've had issues with that in the past when using C++ or Java)

If anyone wants to add me to skype to see if we can hash this thing out, or possibly tell me what it is I've done wrong, feel free to let me know.
User avatar
qwertyman20
 
Posts: 9
Joined: Sat Aug 02, 2014 8:55 am

Re: Help Debugging?

Postby Xenophiliac » Sun Aug 10, 2014 8:24 am

I know it's probably a bad idea to ask, but I'm just touching base here and making sure what I'm doing is the correct thing.

I'm hoping I can have someone's help on debugging and figuring out why my Inform doesn't seem to want to run FS. I know how to patch my own code in a few languages, but with inform and all of these extensions, I'm not sure if the issue is exactly where the error page says it is. (I've had issues with that in the past when using C++ or Java)

If anyone wants to add me to skype to see if we can hash this thing out, or possibly tell me what it is I've done wrong, feel free to let me know.


I'm relatively new to I7, but i've gotten FS to compile and run in Inform 7 and all that. I'm free to help whenever if you need it.
Man ideas are weird.
User avatar
Xenophiliac
 
Posts: 86
Joined: Sat Aug 02, 2014 5:39 am

Re: Help Debugging?

Postby namingway » Fri Sep 26, 2014 8:14 pm

i am unable to get flexible survival to compile in inform7. not sure what I am doing wrong. this is what the error looks like. http://puu.sh/bPpbd/6cf65646bd.png
namingway
 
Posts: 2
Joined: Fri Sep 26, 2014 8:12 pm

Re: Help Debugging?

Postby Wahn » Fri Sep 26, 2014 9:38 pm

namingway wrote:i am unable to get flexible survival to compile in inform7. not sure what I am doing wrong. this is what the error looks like. http://puu.sh/bPpbd/6cf65646bd.png


Click the console button in the upper right corner and you'll get a detailed list with line and column in which file things went wrong...
User avatar
Wahn
 
Posts: 527
Joined: Mon Dec 09, 2013 2:57 pm

Re: Help Debugging?

Postby namingway » Fri Sep 26, 2014 11:24 pm

http://puu.sh/bPxFf/e3d33b0573.png this is what they are looking at, what exactly should I be doing
namingway
 
Posts: 2
Joined: Fri Sep 26, 2014 8:12 pm

Re: Help Debugging?

Postby Wahn » Fri Sep 26, 2014 11:35 pm

Yes, but what is the actual error message in the console? Just showing a piece of code doesn't help much - or did you poke around in the section that you showed?

Did you set the project up with the code package from the GitHub? All extensions going into the Extensions folder (still in their subfolders), while the Inform/Story.ni goes into the Projects\Flexible Survival.inform\Source folder?
User avatar
Wahn
 
Posts: 527
Joined: Mon Dec 09, 2013 2:57 pm

Re: Help Debugging?

Postby TigerStripes » Sat Sep 27, 2014 3:29 am

It appears that Inform's recently come out with a another new release for Inform7 (6L38) and that this includes an update to "simplify how colours are set"... which means that our current addition to the table of User Styles has become invalid. I'd recommend you download the previous version of Inform7 (6L02) for the moment, as I expect the resolution of this error will produce at least a few other change induced issues to appear before we're able to get the game to again compile properly. While the change log states that this version is mostly bug fixes, given the size and scope of our game, it's likely that something else will have a hiccup.

Nuku, can you look into making the necessary updates and corrections to get the game running on the new version of Inform? The text formatting issue is appearing because of changes of the 'Glulx Text Effects by Emily Short' extension, so our addition to the table will need to be revised to suit this new formatting.
User avatar
TigerStripes
 
Posts: 593
Joined: Mon Dec 09, 2013 4:39 pm

Re: Help Debugging?

Postby Sprekken » Tue Jan 27, 2015 6:43 pm

I've installed the 6L02 version and still have the same problem with the table of User Styles. How do I get this to work?

Edit: Nevermind, I swear I tried 6L38 first.
Sprekken
 
Posts: 1
Joined: Tue Jan 27, 2015 5:34 pm


Return to Dev Chat

Who is online

Users browsing this forum: No registered users and 1 guest